1. Guest,
    We need good tech writers that are willing to help out here at ZL-OA. If you like taking photos of jobs as you perform the steps on your repairs, have historical ads/documents from old magazines, or any else you think belongs in the Technical Library than you might be able to help. Send a private message to Furchin, Mudrunner88, Chris, Jarney, Wuputt, or Markus56 and we can lead you in the right direction to get started.
    Dismiss Notice

Coils 85 zl900

Graphixman Mar 13, 2019

  1. Graphixman

    Graphixman Member

    3
    0
    11
    What’s out there as far as getting new oem coils or aftermarket? If aftermarket what works on these bikes the best ????? Freeking parts ... I don’t think I’ll find them ..
     
  2. 87kawzl

    87kawzl Supporting Member

    1,421
    104
    158
  3. prfixer

    prfixer Senior Member Supporting Member

    1,360
    39
    143
    On your other post, you said your bike "lost spark". Do you have no fire on any cylinder?
     
  4. Graphixman

    Graphixman Member

    3
    0
    11
    no fire at all in any of them ,,and on top of it my starter relay took a ****!!! other then that the pic ran perfect 2 seasons ago ..only has 7000 miles but yes im trying to get her back from the dead at moment .. any suggestions?
     
  5. rammy1500

    rammy1500 Supporting Member

    934
    4
    113
    I replaced my coils last summer with ones off of flea-bay by DG electric, about $40 each. Worked fine but one burned out on the second time out, they sent me a replacement (really return and new purchase) rode the rest of the summer and all last week in Daytona, no issues. Seems to fire much better than the old originals. You might want to do plugs, wires and new boots all at the same time.
     
  6. Raf900

    Raf900 Member

    24
    8
    13
    I use the Dyna coils, 8mm wires with Irridium plugs. Good clean spark. they are on the Dale Walker Holeshot link.
     
  7. rkerg

    rkerg Senior Member

    You can get the starter rebuilt for much less than the cost of a new one.
    I had mine done last summer for $75.
     
  8. prfixer

    prfixer Senior Member Supporting Member

    1,360
    39
    143
    I would think it unusual for both coils to lose spark simultaneously and have it be that the coils failed. You have pulled the plugs and grounded them to the engine to verify no spark anywhere? Was anything done to the bike these last 2 years that would have involved wiring changes? Any possibility of rodent damage(chewed wires, etc.)? is the CDI unit installed or do you have a spare to try?
     
  9. R. J.

    R. J. Senior Member

    7,900
    305
    128
    :hello: Are you saying the starter solenoid went bad or is it your starter.
     

Share This Page