1. Guest,
    We need good tech writers that are willing to help out here at ZL-OA. If you like taking photos of jobs as you perform the steps on your repairs, have historical ads/documents from old magazines, or any else you think belongs in the Technical Library than you might be able to help. Send a private message to Furchin, Mudrunner88, Chris, Jarney, Wuputt, or Markus56 and we can lead you in the right direction to get started.
    Dismiss Notice

Pingel Petcock

DirtyRider Jun 9, 2019

  1. DirtyRider

    DirtyRider Member

    89
    7
    18
    Does anyone know if the 4311-CR will work on a ZL900-A?
     
  2. nitroshot

    nitroshot Well-Known Member

    51
    0
    91
    Not sure of their part # but with adapter I had to enlarge the center of hole to about 5/8" for mine.
     

    Attached Files:

  3. Theodore Dekeyser

    Theodore Dekeyser New Member

    25
    1
    3
    How did the Pingel work out for you? Leaks? Adequate flow?

    My zl600 didn't have a petcock when I bought it and I just recieved this one from eBay, says it's for a kz440 and a couple other Kawi's. This one is vacuum operated whereas the stock one I don't believe was, it was gravity fed from what I can tell. Do you guys think this will work if I run the vac line to one of the capped off carb nipples?
     

    Attached Files:

  4. furchin

    furchin ZL-OA Co-owner Staff Member Administrator Super Moderator Supporting Member

    2,122
    66
    143
    If the bolt holes line up and the feed tube is not too long it should work. And the stock petcock for a 600 is indeed vacuum operated.
     
  5. R. J.

    R. J. Supporting Member

    8,563
    412
    128
    :hello: I think the Factory runs the vacuum line from the petcock/fuel valve to the #2 carbs vacuum port on most of all inline 4s.
     
  6. Theodore Dekeyser

    Theodore Dekeyser New Member

    25
    1
    3
    Yes your correct I just found one on ebay where they had pics of the back too and yes there is another nipple and vac diaphragm.

    I'm not able to get any fuel into the carbs for some reason. I can get fuel to flow if I suck on the vac line but nothing is flowing when it's hooked up to the 1st carb nipple?
     
  7. Theodore Dekeyser

    Theodore Dekeyser New Member

    25
    1
    3
    Is it possible I need to run the vacuum reference line split to 2 of the carbs? I'm not getting fuel flow and I dunno why, it flows if I suck on the vac line?
     
  8. R. J.

    R. J. Supporting Member

    8,563
    412
    128
    :hello: Fuel won't flow unless the bike is running because it operates on vacuum. Your fuel valve has a prime setting PRI. It's top center. It should only be used to flow fuel to the carbs when they are empty.
     
  9. Theodore Dekeyser

    Theodore Dekeyser New Member

    25
    1
    3
    Dammit I can't figure out why it won't start? It starts on starting fluid but won't on gas. It seems the bowls fill up when on PRI but in the ON position nothing comes down the fuel line. Fuel will flow if I suck on the vac line but not if attached to thecarb nipple, any ideas?
     
  10. prfixer

    prfixer Senior Member Supporting Member

    1,427
    54
    143
    If the bowls are full of gas, your problem lies somewhere beside the petcock. PRI position will fill the bowls sans vacuum. Have your carbs been rebuilt? Have they sat and become gummed up?
     
  11. 87kawzl

    87kawzl Supporting Member

    1,641
    155
    158
    Hook carb #2 up to it and cap the rest.
     
  12. Theodore Dekeyser

    Theodore Dekeyser New Member

    25
    1
    3
    They had sat yes but I went thru them meticulously and they should be perfect. I'm kinda at a standstill, I know I'm missing something but there's not much to it I just need to find what it is?
     
  13. Theodore Dekeyser

    Theodore Dekeyser New Member

    25
    1
    3
    That's how I've got it hooked up per recommendation from you guys. But fuel doesn't flow unless I suck on the vac line. Maybe the Petcock is faulty?
     
  14. prfixer

    prfixer Senior Member Supporting Member

    1,427
    54
    143
    If you are able to fill the bowls using the PRI position, and everything is functioning correctly except the vacuum operated side of the petcock, the bike would start and run until the gas was exhausted from the bowls.
     
  15. R. J.

    R. J. Supporting Member

    8,563
    412
    128
    :hello: May be the fuel tanks breather is being restricted. Try starting the bike with the gas cap opened.
     
  16. 87kawzl

    87kawzl Supporting Member

    1,641
    155
    158
    If you can make the petcock flow by sucking on the vacuum line the problem is with the carbs pulling a vacuum. Make sure your carb holders are not leaking and all vacuum plugs are sealing well.

    Run the bike on pri and check the hose on #2 to see if it is draw a vacuum.
     
  17. prfixer

    prfixer Senior Member Supporting Member

    1,427
    54
    143
    Did I miss that you can now start it?
     
  18. R. J.

    R. J. Supporting Member

    8,563
    412
    128
    :hello: Do you still have the OEM fuel valve that came on your bike. If so you may want to go ahead and rebuild it. The one you bought that is for a different bike is it aftermarket. If so it is most likely CHINA junk. I've tried several CHINA junk ones on bikes in the past and everyone failed. They seem to never pull enough fuel. You can still buy all the 86 ZL 600 OEM parts from KAW. You will need part # 11009-1188, 43028-1021, 43058=51039-003, 92022-183, 92055-1085 and 92081-1240. partzilla has them all in stock. https://www.partzilla.com/catalog/kawasaki/motorcycle/1986/zl600-eliminator-zl600-a1/fuel-tank Pic #1 86 ZL 6 fuel valve. Pic #2 ZL 1000 fuel valve is for referance. ________________________________________ IMG_7732.JPG IMG_7731.JPG
     
  19. Theodore Dekeyser

    Theodore Dekeyser New Member

    25
    1
    3
    Thanks for all the good advice guys. So no I can't start it unless I give it some starting fluid. And yes to the factory petcock, especially if the Chinese generics like the one I bought for 10$ have failed so often it's not where I want to try and save a buck.... Nowhere is really and the petcock is no exception. So...

    1.Purchase factory petcock - rebuild it
    2. Cyl. 2&3 are missing clamps on the carb side I just realized so install clamps there.
    3. Test breather line, start w/ cap open
    4. Vac guage test each carb for proper vacuum.

    Anybody know how much Hg it's set to pull ?
     
  20. Theodore Dekeyser

    Theodore Dekeyser New Member

    25
    1
    3
    Check out this tank I picked up today for 40$!! Picked up locally so no shipping. I hit it with the cut-polish-paste wax 3 step process and damn it's looking good.

    Now I've got a painted tank nobody will even notice the rest of the bike is actually vinyl. That and wrapping the tank is a task for seasoned wrap pro... That s*** is hard!!
     

Share This Page